WordPress Plugin 'LearnDash' < 3.1.6 SQLi

critical Nessus Plugin ID 136286

Synopsis

The remote WordPress application has a plugin installed that is vulnerable to a SQL Injection (SQLi) vulnerability.

Description

The WordPress application running on the remote host has a version of the 'LearnDash' plugin that is prior to 3.1.6 and, thus, is affected by a SQL Injection (SQLi) exists in the 'learndash_get_course_groups' function in the ld-groups.php file due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data.

Solution

Update the 'LearnDash' plugin to version 3.1.6 or later through the administrative dashboard.

See Also

http://www.nessus.org/u?b38b6cba

https://learndash.releasenotes.io/release/YBfaq-version-316

Plugin Details

Severity: Critical

ID: 136286

File Name: wordpress_plugin_learndash_3_1_6.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 5/4/2020

Updated: 5/5/2020

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-6009

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress, cpe:/a:learndash:learndash

Required KB Items: installed_sw/LearnDash

Exploit Ease: No known exploits are available

Patch Publication Date: 4/1/2020

Vulnerability Publication Date: 4/1/2020

Reference Information

CVE: CVE-2020-6009