WordPress Plugin 'LearnPress' < 3.2.6.8 Multiple Vulnerabilities

high Nessus Plugin ID 136191

Synopsis

The remote WordPress application has a plugin installed that is vulnerable to multiple vulnerabilities.

Description

The WordPress application running on the remote host has a version of the 'LearnPress' plugin that is prior to 3.2.6.8 and, thus, is affected by multiple vulnerabilities :

- A SQL injection (SQLi) vulnerability exists in the _get_items method of the LP_Modal_Search_Items class due to improper validation of user-supplied input. An authenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data. (CVE-2020-6010)

- A privilege escalation vulnerability exists in the learn_press_accept_become_a_teacher function due to the code not checking the permissions of the requesting user. An unauthenticated, remote attacker can exploit this, via /wpadmin/, to gain 'teacher' access to the application. (CVE-2020-11511)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Update the 'LearnPress' plugin to version 3.2.6.8 or later through the administrative dashboard.

See Also

http://www.nessus.org/u?b38b6cba

https://wordpress.org/plugins/learnpress/#developers

Plugin Details

Severity: High

ID: 136191

File Name: wordpress_plugin_learnpress_3_2_6_8.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 5/1/2020

Updated: 5/13/2022

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS Score Source: CVE-2020-11511

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

CVSS Score Source: CVE-2020-6010

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/30/2020

Vulnerability Publication Date: 3/30/2020

Reference Information

CVE: CVE-2020-6010, CVE-2020-11511