WordPress Plugin 'LifterLMS' < 3.37.15 Arbitrary File Write

critical Nessus Plugin ID 136176

Synopsis

The remote WordPress application has a plugin installed that is vulnerable to an arbitrary file write vulnerability.

Description

The WordPress application running on the remote host has a version of the 'LifterLMS' plugin that is prior to 3.37.15 and, thus, is affected by an arbitrary file write vulnerability that can allow the attackers to write and execute arbitrary PHP code on the server by changing their first name on their profile to PHP code.

Solution

Update the 'LifterLMS' plugin to version 3.37.15 or later through the administrative dashboard.

See Also

http://www.nessus.org/u?b38b6cba

https://make.lifterlms.com/2020/03/30/lifterlms-version-3-37-15/

Plugin Details

Severity: Critical

ID: 136176

File Name: wordpress_plugin_lifterlms_3_37_15.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 4/30/2020

Updated: 5/1/2020

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-6008

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: installed_sw/WordPress, www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 3/30/2020

Vulnerability Publication Date: 3/30/2020

Reference Information

CVE: CVE-2020-6008