libssh2 < 1.8.1 Integer Overflow Vulnerability.

High Nessus Plugin ID 135851

Synopsis

The libssh2 version running on the remote host is affected by an integer overflow vulnerability.

Description

An integer overflow condition exists in libssh2 before 1.8.1 due to the way packets are read from the server. An authenticated, local attacker can exploit this if they have already compromised an SSH server. The attacker may be able to execute code on the system of users who connect to the SSH server.

Solution

Upgrade to libssh2 version 1.8.1 or later.

See Also

https://www.libssh2.org/CVE-2019-3855.html

Plugin Details

Severity: High

ID: 135851

File Name: macosx_libssh2_cve_2019_3855.nasl

Version: 1.2

Type: local

Agent: macosx

Published: 2020/04/21

Updated: 2020/04/23

Dependencies: 12634, 83991

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-3855

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a::libssh2

Required KB Items: Host/MacOSX/Version, Host/MacOSX/packages

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/03/18

Vulnerability Publication Date: 2018/12/03

Reference Information

CVE: CVE-2019-3855

BID: 107485