Exim < 4.93 Privilege Escalation vulnerability

High Nessus Plugin ID 135311

Synopsis

The remote mail server is potentially affected by a privilege escalation vulnerability.

Description

According to its banner, the version of Exim running on the remote host is prior to 4.93. It is, therefore, potentially affected by a privilege escalation vulnerability. A flaw exists in the UNIX symbolic link that could allow an attacker to execute to escalate from the mail user to root.

Solution

Upgrade to Exim 4.93 or later.

See Also

http://www.nessus.org/u?f294b9cf

http://www.nessus.org/u?cc28c77b

http://www.nessus.org/u?728dbb7f

Plugin Details

Severity: High

ID: 135311

File Name: exim_4_93.nasl

Version: 1.3

Type: remote

Published: 2020/04/10

Updated: 2020/04/13

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2020-8015

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/04/10

Vulnerability Publication Date: 2020/04/01

Reference Information

CVE: CVE-2020-8015

IAVA: 2020-A-0131