GLSA-202004-04 : Qt WebEngine: Arbitrary code execution

high Nessus Plugin ID 135115

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202004-04 (Qt WebEngine: Arbitrary code execution)

A use-after-free vulnerability has been found in the audio component of Qt WebEngine.
Impact :

A remote attacker could entice a user to open a specially crafted media file in an application linked against Qt WebEngine, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Qt WebEngine users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-qt/qtwebengine-5.14.1'

See Also

https://security.gentoo.org/glsa/202004-04

Plugin Details

Severity: High

ID: 135115

File Name: gentoo_GLSA-202004-04.nasl

Version: 1.5

Type: local

Published: 4/2/2020

Updated: 5/27/2022

Risk Information

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS Score Source: CVE-2019-13720

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:qtwebengine, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/1/2020

Vulnerability Publication Date: 11/25/2019

CISA Known Exploited Dates: 6/13/2022

Reference Information

CVE: CVE-2019-13720

GLSA: 202004-04