RHEL 7 : wireshark (RHSA-2020:1047)

high Nessus Plugin ID 135076
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2020:1047 advisory.

- wireshark: Out-of-bounds read in packet-ldss.c (CVE-2018-11362)

- wireshark: Multiple dissectors could crash (wnpa-sec-2018-36) (CVE-2018-14340)

- wireshark: DICOM dissector infinite loop (wnpa-sec-2018-39) (CVE-2018-14341)

- wireshark: Bazaar dissector infinite loop (wnpa-sec-2018-40) (CVE-2018-14368)

- wireshark: Radiotap dissector crash (CVE-2018-16057)

- wireshark: Infinite loop in the MMSE dissector (CVE-2018-19622)

- wireshark: SIGCOMP dissector crash in packet-sigcomp.c (CVE-2018-7418)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected wireshark, wireshark-devel and / or wireshark-gnome packages.

See Also

https://cwe.mitre.org/data/definitions/125.html

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/400.html

https://cwe.mitre.org/data/definitions/835.html

https://access.redhat.com/errata/RHSA-2020:1047

https://access.redhat.com/security/cve/CVE-2018-11362

https://access.redhat.com/security/cve/CVE-2018-14340

https://access.redhat.com/security/cve/CVE-2018-14341

https://access.redhat.com/security/cve/CVE-2018-14368

https://access.redhat.com/security/cve/CVE-2018-16057

https://access.redhat.com/security/cve/CVE-2018-19622

https://access.redhat.com/security/cve/CVE-2018-7418

https://bugzilla.redhat.com/1549305

https://bugzilla.redhat.com/1581787

https://bugzilla.redhat.com/1607323

https://bugzilla.redhat.com/1607326

https://bugzilla.redhat.com/1607327

https://bugzilla.redhat.com/1625925

https://bugzilla.redhat.com/1655932

Plugin Details

Severity: High

ID: 135076

File Name: redhat-RHSA-2020-1047.nasl

Version: 1.6

Type: local

Agent: unix

Published: 4/1/2020

Updated: 10/13/2021

Dependencies: ssh_get_info.nasl, redhat_repos.nasl

Risk Information

CVSS Score Source: CVE-2018-14368

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:redhat:enterprise_linux:7:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:wireshark:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:wireshark-gnome:*:*:*:*:*:*:*, p-cpe:2.3:a:redhat:enterprise_linux:wireshark-devel:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 3/31/2020

Vulnerability Publication Date: 2/23/2018

Reference Information

CVE: CVE-2018-7418, CVE-2018-11362, CVE-2018-14340, CVE-2018-14341, CVE-2018-14368, CVE-2018-16057, CVE-2018-19622

BID: 104847, 106051, 103157, 104308, 105174

CWE: 20, 125, 400, 835

RHSA: 2020:1047

IAVB: 2018-B-0032-S, 2018-B-0072-S, 2018-B-0093-S, 2018-B-0120-S, 2018-B-0154-S