Drupal 5.x < 5.11 / 6.x < 6.5 Multiple Vulnerabilities (SA-2008-060)

High Nessus Plugin ID 134979

Synopsis

The PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

The version of Drupal running on the remote web server is 5.x prior to 5.11 or 6.x prior to 6.5. It is, therefore, affected by the following vulnerabilities:

- The validation functionality in the core upload module in Drupal 6.x before 6.5 allows remote, authenticated users to bypass intended access restrictions and attach files to content, related to a logic error. (CVE-2008-4789)
- The core upload module in Drupal 5.x before 5.11 allows remote authenticated users to bypass intended access restrictions and read files attached to content via unknown vectors.(CVE-2008-4790)

- The user module in Drupal 5.x before 5.11 and 6.x before 6.5 allows remote authenticated users to bypass intended login access rules and successfully login via unknown vectors.(CVE-2008-4791)

- The core BlogAPI module in Drupal 5.x before 5.11 and 6.x before 6.5 does not properly validate unspecified content fields of an internal Drupal form, which allows remote, authenticated users to bypass intended access restrictions via modified field values. (CVE-2008-4792)

- The node module API in Drupal 5.x before 5.11 allows remote attackers to bypass node validation and have unspecified other impact via unknown vectors related to contributed modules. (CVE-2008-4793)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Drupal version 5.11, 6.5, or later.

See Also

https://www.drupal.org/node/318706

https://www.drupal.org/project/drupal/releases/5.11

https://www.drupal.org/project/drupal/releases/6.5

Plugin Details

Severity: High

ID: 134979

File Name: drupal_6_5.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2020/03/30

Updated: 2020/03/31

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2008-4793

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: www/PHP, installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/10/08

Vulnerability Publication Date: 2008/10/08

Exploitable With

Core Impact

Reference Information

CVE: CVE-2008-4789, CVE-2008-4790, CVE-2008-4791, CVE-2008-4792, CVE-2008-4793

BID: 84731, 84742, 84753, 84778, 84780