PHP 7.2.x < 7.2.29 Multiple Vulnerabilities

Medium Nessus Plugin ID 134949

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.2.x prior to 7.2.29. It is, therefore, affected by multiple vulnerabilities:
- A NULL pointer de-reference flaw exists in PHP's Exif component due to its implementation attempting to use uninitialized bytes. An unauthenticated, remote attacker can exploit this to cause a denial of service condition when the application attempts to read or write memory with a NULL pointer. (CVE-2020-7064)

- An information disclosure vulnerability exists in PHP due to the `get_headers` function silently truncating anything it receives, after a null byte. An unauthenticated, remote attacker can exploit this, by supplying URLs containing a null byte, to disclose potentially sensitive information.
(CVE-2020-7066)

Solution

Upgrade to PHP version 7.2.29 or later.

See Also

https://php.net/ChangeLog-7.php#7.2.29

Plugin Details

Severity: Medium

ID: 134949

File Name: php_7_2_29.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2020/03/27

Updated: 2020/04/24

Dependencies: 48243

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-7064

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/03/19

Vulnerability Publication Date: 2020/03/19

Reference Information

CVE: CVE-2020-7064, CVE-2020-7066

IAVA: 2020-A-0117-S