GLSA-202003-12 : sudo: Multiple vulnerabilities

high Nessus Plugin ID 134589

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-202003-12 (sudo: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in sudo. Please review the CVE identifiers referenced below for details.
Impact :

A local attacker could expose or corrupt memory information, inject code to be run as a root user or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All sudo users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-admin/sudo-1.8.31'

See Also

https://security.gentoo.org/glsa/202003-12

Plugin Details

Severity: High

ID: 134589

File Name: gentoo_GLSA-202003-12.nasl

Version: 1.2

Type: local

Published: 3/16/2020

Updated: 3/18/2020

Risk Information

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:sudo, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/14/2020

Vulnerability Publication Date: 10/17/2019

Reference Information

CVE: CVE-2019-14287, CVE-2019-18634

GLSA: 202003-12