Debian DLA-2133-1 : tomcat7 security update

critical Nessus Plugin ID 134243
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security update.

Description

Several security vulnerabilities have been discovered in the Tomcat servlet and JSP engine.

CVE-2019-17569

The refactoring in 7.0.98 introduced a regression. The result of the regression was that invalid Transfer-Encoding headers were incorrectly processed leading to a possibility of HTTP Request Smuggling if Tomcat was located behind a reverse proxy that incorrectly handled the invalid Transfer-Encoding header in a particular manner. Such a reverse proxy is considered unlikely.

CVE-2020-1935

The HTTP header parsing code used an approach to end-of-line (EOL) parsing that allowed some invalid HTTP headers to be parsed as valid.
This led to a possibility of HTTP Request Smuggling if Tomcat was located behind a reverse proxy that incorrectly handled the invalid Transfer-Encoding header in a particular manner. Such a reverse proxy is considered unlikely.

CVE-2020-1938

When using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections are available to an attacker, they can be exploited in ways that may be surprising. Prior to Tomcat 7.0.100, Tomcat shipped with an AJP Connector enabled by default that listened on all configured IP addresses. It was expected (and recommended in the security guide) that this Connector would be disabled if not required.

Note that Debian already disabled the AJP connector by default. Mitigation is only required if the AJP port was made accessible to untrusted users.

For Debian 8 'Jessie', these problems have been fixed in version 7.0.56-3+really7.0.100-1.

We recommend that you upgrade your tomcat7 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2020/03/msg00006.html

https://packages.debian.org/source/jessie/tomcat7

Plugin Details

Severity: Critical

ID: 134243

File Name: debian_DLA-2133.nasl

Version: 1.4

Type: local

Agent: unix

Published: 3/6/2020

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Critical

Score: 9.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libservlet3.0-java, p-cpe:/a:debian:debian_linux:libservlet3.0-java-doc, p-cpe:/a:debian:debian_linux:libtomcat7-java, p-cpe:/a:debian:debian_linux:tomcat7, p-cpe:/a:debian:debian_linux:tomcat7-admin, p-cpe:/a:debian:debian_linux:tomcat7-common, p-cpe:/a:debian:debian_linux:tomcat7-docs, p-cpe:/a:debian:debian_linux:tomcat7-examples, p-cpe:/a:debian:debian_linux:tomcat7-user, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/4/2020

Vulnerability Publication Date: 2/24/2020

Reference Information

CVE: CVE-2019-17569, CVE-2020-1935, CVE-2020-1938