PHP 7.2.x < 7.2.28 / PHP 7.3.x < 7.3.15 / 7.4.x < 7.4.3 Multiple Vulnerabilities

critical Nessus Plugin ID 134162
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is either 7.2.x prior to 7.2.28, 7.3.x prior to 7.3.15, or 7.4.x prior to 7.4.3. It is, therefore, affected by multiple vulnerabilities:

- A heap-based buffer overflow condition exists in phar_extract_file() function due to incorrect loop termination. An unauthenticated, remote attacker can exploit this to cause a denial of service condition or the execution of arbitrary code. (CVE-2020-7061)

- A denial of service (DoS) vulnerability exists in PHP SessionUpload Progress functions due to Null Pointer Dereference. An unauthenticated, remote attacker can exploit this issue to cause the php service to stop responding. (CVE-2020-7062)
- An Insecure File Permissions on the buildFromIterator function gives all access permission to Tar files. (CVE-2020-7063)

Solution

Upgrade to PHP version 7.2.28, 7.3.15, 7.4.3 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.28

http://php.net/ChangeLog-7.php#7.3.15

http://php.net/ChangeLog-7.php#7.4.3

Plugin Details

Severity: Critical

ID: 134162

File Name: php_7_4_3.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2/28/2020

Updated: 4/24/2020

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2020-7061

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2/20/2020

Vulnerability Publication Date: 2/20/2020

Reference Information

CVE: CVE-2020-7061, CVE-2020-7062, CVE-2020-7063