Debian DSA-4623-1 : postgresql-11 - security update

medium Nessus Plugin ID 133700

Synopsis

The remote Debian host is missing a security-related update.

Description

Tom Lane discovered that 'ALTER ... DEPENDS ON EXTENSION' sub commands in the PostgreSQL database did not perform authorisation checks.

Solution

Upgrade the postgresql-11 packages.

For the stable distribution (buster), this problem has been fixed in version 11.7-0+deb10u1.

See Also

http://www.nessus.org/u?4e0872ee

https://packages.debian.org/source/buster/postgresql-11

https://www.debian.org/security/2020/dsa-4623

Plugin Details

Severity: Medium

ID: 133700

File Name: debian_DSA-4623.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2/14/2020

Updated: 3/31/2020

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-1720

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:postgresql-11, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2/13/2020

Vulnerability Publication Date: 3/17/2020

Reference Information

CVE: CVE-2020-1720

DSA: 4623