PHP 7.2.x < 7.2.27 / PHP 7.3.x < 7.3.14 / 7.4.x < 7.4.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 133400

Synopsis

The version of PHP running on the remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is either 7.2.x prior to 7.2.27, 7.3.x prior to 7.3.14, or 7.4.x prior to 7.4.2. It is, therefore, affected by multiple vulnerabilities:

- An buffer overflow on the mbfl_filt_conv_big5_wchar` function. An unauthenticated, remote attacker can exploit this to leading to the disclosure of information within memory locations and possibly allow for the execution of malicious code. (CVE-2020-7060)

- An out-of-bounds READ error exists in the php_strip_tags_ex due to an input validation error. An unauthenticated, remote attacker can exploit this, leading to the disclosure of information within some memory locations. (CVE-2020-7059)

Solution

Upgrade to PHP version 7.2.27, 7.3.14, 7.4.2 or later.

See Also

http://php.net/ChangeLog-7.php#7.2.27

http://php.net/ChangeLog-7.php#7.3.14

http://php.net/ChangeLog-7.php#7.4.2

Plugin Details

Severity: Medium

ID: 133400

File Name: php_7_4_2.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2020/01/31

Updated: 2020/02/28

Dependencies: 48243

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2020-7060

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2020/01/23

Vulnerability Publication Date: 2020/01/23

Reference Information

CVE: CVE-2020-7059, CVE-2020-7060