Oracle Primavera Unifier Multiple Vulnerabilities (Jan 2020 CPU)

High Nessus Plugin ID 133359

Synopsis

An application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Oracle Primavera Unifier installation running on the remote web server is 16.1.x or 16.2.x prior to 16.2.16.0, or 17.7.x through 17.12.x prior to 17.12.11.2, or 18.8.x prior to 18.8.15, or 19.12.x prior to 19.12.0.1. It is, therefore, affected by multiple vulnerabilities:

- A Polymorphic Typing issue was discovered in FasterXML jackson-databind before 2.9.10 used in Primavera Unifier.
(CVE-2019-14540)

- A memory exhaustion flaw exists in Apache Tika's RecursiveParserWrapper versions 1.7 - 1.21 used in Primavera Unifier. (CVE-2019-10088)

- A Server Side Request Forgery (SSRF) vulnerability affected the Apache Axis 1.4 distribution that was last released in 2006. Security and bug commits commits continue in the projects Axis 1.x Subversion repository, legacy users are encouraged to build from source. The successor to Axis 1.x is Axis2, the latest version is 1.7.9 and is not vulnerable to this issue. (CVE-2019-0227)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Oracle Primavera Unifier version 16.2.16.0 / 17.12.11.2 / 18.8.15 / 19.12.0.1 or later.

See Also

http://www.nessus.org/u?b244b132

Plugin Details

Severity: High

ID: 133359

File Name: oracle_primavera_unifier_cpu_jan_2020.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2020/01/30

Updated: 2020/05/06

Dependencies: 101904

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-14540

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/a:oracle:primavera_unifier

Required KB Items: installed_sw/Oracle Primavera Unifier, www/weblogic

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2020/01/14

Vulnerability Publication Date: 2020/01/14

Reference Information

CVE: CVE-2014-3596, CVE-2018-8032, CVE-2019-0227, CVE-2019-10088, CVE-2019-10093, CVE-2019-10094, CVE-2019-12415, CVE-2019-14540, CVE-2019-16335

BID: 107867

IAVA: 2020-A-0140