Debian DLA-2060-1 : phpmyadmin security update

high Nessus Plugin ID 132940

Synopsis

The remote Debian host is missing a security update.

Description

In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.

For Debian 8 'Jessie', this problem has been fixed in version 4:4.2.12-2+deb8u8.

We recommend that you upgrade your phpmyadmin packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected phpmyadmin package.

See Also

https://lists.debian.org/debian-lts-announce/2020/01/msg00011.html

https://packages.debian.org/source/jessie/phpmyadmin

Plugin Details

Severity: High

ID: 132940

File Name: debian_DLA-2060.nasl

Version: 1.6

Type: local

Agent: unix

Published: 1/16/2020

Updated: 1/11/2021

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2020-5504

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:phpmyadmin, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/15/2020

Vulnerability Publication Date: 1/9/2020

Reference Information

CVE: CVE-2020-5504