nginx 0.8.x < 0.8.33 / 0.7.x < 0.7.65 Windows Filename Pseudonyms (CORE-2010-0121)

Medium Nessus Plugin ID 132775


The remote web server is affected by a vulnerability.


According to its server response header, the installed version of nginx is 0.7.52 and prior to 0.7.65, or 0.8.x prior to 0.8.33. It is, therefore, affected by a flaw in Windows installations of nginx. This is due to nginx mishandling DOS-compatible 8.3 short filenames. An unauthenticated, remote attacker can exploit this, via web requests, to potentially bypass server-side include (SSI) directives.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to nginx 0.7.65 or 0.8.33 or later.

See Also

Plugin Details

Severity: Medium

ID: 132775

File Name: nginx_CORE-2010-0121.nasl

Version: 1.3

Type: combined

Agent: unix

Family: Web Servers

Published: 2020/01/13

Updated: 2020/05/08

Dependencies: 136340, 106375

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the corelabs advisory.

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: installed_sw/nginx

Patch Publication Date: 2010/02/01

Vulnerability Publication Date: 2010/02/05

Reference Information

CWE: 22, 755