Atlassian JIRA < 7.13.6 / 8.x < 8.4.0 XSS (JRASERVER-69795)

Low Nessus Plugin ID 132722

Synopsis

The remote web server hosts a web application that is affected by a cross-site scripting (XSS) vulnerability.

Description

According to its self-reported version number, the instance of Atlassian JIRA hosted on the remote web server is prior to 7.13.6, or 8.x prior to 8.4.0. It is, therefore, affected by a cross-site scripting (XSS) vulnerability. The vulnerability exists in the Optimization plugin due to improper validation of user-supplied input before returning it to users. An authenticated, remote attacker can exploit this, via the name of a custom field, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to Atlassian JIRA version 7.13.6 / 8.4.0

See Also

https://jira.atlassian.com/browse/JRASERVER-69795

Plugin Details

Severity: Low

ID: 132722

File Name: jira_8_4_0_cve-2019-8450.nasl

Version: 1.3

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 2020/01/09

Updated: 2020/07/28

Dependencies: 45577, 131566, 131193

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2019-8450

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:jira

Required KB Items: installed_sw/Atlassian JIRA

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/08/26

Vulnerability Publication Date: 2019/09/11

Reference Information

CVE: CVE-2019-8450