Apache Solr < 8.4.0 Remote Code Execution

Medium Nessus Plugin ID 132583

Synopsis

The remote web server contains a Java application that is affected by a remote code execution vulnerability.

Description

The version of Apache Solr running on the remote host is at least 5.0.0 and prior to 8.4.0. It is, therefore, affected by a remote code execution vulnerability. A remote code execution vulnerability exists in VelocityResponseWriter due to a flaw in the velocity template parameter. An unauthenticated, remote attacker can exploit this to bypass authentication and execute arbitrary commands with the privileges of Apache Solr.

Solution

Upgrade to Apache Solr version 8.4.0 or later.

See Also

http://lucene.apache.org/solr/news.html

https://issues.apache.org/jira/browse/SOLR-13971

https://issues.apache.org/jira/browse/SOLR-14025

https://vuldb.com/?id.147906

http://www.nessus.org/u?b63da8fd

Plugin Details

Severity: Medium

ID: 132583

File Name: solr_8_4_0.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2020/01/02

Updated: 2020/04/06

Dependencies: 71843

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-17558

CVSS v2.0

Base Score: 6

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:solr

Required KB Items: installed_sw/Apache Solr

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/12/29

Vulnerability Publication Date: 2019/10/29

Exploitable With

Metasploit (Apache Solr Remote Code Execution via Velocity Template)

Reference Information

CVE: CVE-2019-17558