Ansible Tower 3.5.x < 3.5.4 / 3.6.x < 3.6.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 132319

Synopsis

An IT monitoring application running on the remote host is affected by an Information Disclosure vulnerability.

Description

The version of Ansible Tower running on the remote web server is 3.5.x prior to 3.5.4 or 3.6.x prior to 3.6.2. It is, therefore, affected by multiple vulnerabilities.

- An information disclosure vulnerability exists in the Sumologic and Splunk callback plugins due to Ansible not respecting the 'no_log' flag. A remote attacker can exploit this via the plugin collectors to potentially disclose sensitive information. (CVE-2019-14864)

- A flaw exists in RabbitMQ manager with the rabbitmq_enable_manager setting due to the setting exposing the RabbigMQ manager management interface publicly, which may still have the default admin user active. An unauthenticated, remote attacker can exploit this by guessing the default admin credentials and gain access to the system. (CVE-2019-19340)

- An information disclosure vulnerability exists in Ansible Tower backups, due to files in '/var/backup/tower' being left world-readable while a Tower backup is running. An authenticated, remote attacker with knowledge of the backup can exploit this by navigating to the '/var/backup/tower' directory and accessing the files, which includes both the SECRET_KEY, backup files, and every credential stored in Tower. (CVE-2019-19341)

- An information disclosure vulnerability exists in '/websocket' due to Ansible Tower mishandling passwords with the '#' character, and partially disclosing plaintext passwords when '/websocket' is requested. An unauthenticated, remote attacker can exploit this via HTTP to disclose partial passwords, allowing the attacker to brute force or guess predictable passwords. (CVE-2019-19342)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Ansible Tower version 3.5.4, 3.6.2, or later.

See Also

https://access.redhat.com/errata/RHSA-2019:4242

https://access.redhat.com/errata/RHSA-2019:4243

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14864

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19340

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19341

https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19342

Plugin Details

Severity: Medium

ID: 132319

File Name: ansible_tower_3_6_2.nasl

Version: 1.5

Type: combined

Family: CGI abuses

Published: 2019/12/20

Updated: 2020/05/27

Dependencies: 112215, 112214

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-19340

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.2

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ansible:tower

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/12/16

Vulnerability Publication Date: 2019/12/14

Reference Information

CVE: CVE-2019-14864, CVE-2019-19340, CVE-2019-19341, CVE-2019-19342