CODESYS ENI Server < 3.2.2.25 Stack Overflow (credentialed check)

critical Nessus Plugin ID 131736
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A SCADA application on the remote host is affected by a remote code execution vulnerability.

Description

A stack-based buffer overflow condition exists in CODESYS ENI server due to improper validation of user-supplied data. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to cause a denial of service condition or the execution of arbitrary code.

Solution

Upgrade CODESYS ENI server to version 3.2.2.25 or higher.

See Also

http://www.nessus.org/u?1a63c71f

Plugin Details

Severity: Critical

ID: 131736

File Name: scada_codesys_eni_server_3_2_2_25.nbin

Version: 1.19

Type: local

Agent: windows

Family: SCADA

Published: 12/6/2019

Updated: 11/29/2021

Dependencies: scada_app_codesys2_detect.nbin

Risk Information

CVSS Score Source: CVE-2019-16265

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:3s-software:codesys

Required KB Items: installed_sw/CODESYS

Exploit Ease: No known exploits are available

Patch Publication Date: 10/23/2019

Vulnerability Publication Date: 10/23/2019

Reference Information

CVE: CVE-2019-16265

IAVA: 2019-A-0435