SSL/TLS Deprecated Ciphers

Info Nessus Plugin ID 131290

Synopsis

The remote host uses deprecated SSL/TLS ciphers

Description

The remote host has open SSL/TLS ports which advertise deprecated cipher suites. The ciphers contained in these suites are no longer supported by most major ssl libraries such as OpenSSL, NSS, Mbed TLS, and wolfSSL and, as such, should not be used for secure communication.

Nessus 8.9 and later no longer supports these ciphers.

Solution

Upgrade to a cipher suite which does not contain deprecated ciphers.

Plugin Details

Severity: Info

ID: 131290

File Name: ssl_deprecated_ciphers.nasl

Version: 1.5

Type: remote

Family: General

Published: 2019/11/26

Updated: 2020/06/02

Dependencies: 21643

Risk Information

Risk Factor: Info

Vulnerability Information

Excluded KB Items: global_settings/disable_test_ssl_based_services