Artifex Ghostscript < 9.50 Multiple Vulnerabilities

critical Nessus Plugin ID 130273
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a library that is affected by multiple vulnerabilities.

Description

The version of Artifex Ghostscript installed on the remote Windows host is prior to 9.50. It is, therefore, affected by multiple security bypass vulnerabilities. An attacker could exploit one of these vulnerabilities to gain access to the file system and execute arbitrary commands.

Solution

Upgrade to Artifex Ghostscript 9.50 or later.

See Also

https://www.ghostscript.com/Ghostscript_9.50.html

Plugin Details

Severity: Critical

ID: 130273

File Name: ghostscript_9_50.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 10/25/2019

Updated: 7/5/2021

Dependencies: ghostscript_detect.nbin

Risk Information

CVSS Score Source: CVE-2019-14813

VPR

Risk Factor: Critical

Score: 9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:artifex:ghostscript, cpe:/a:artifex:gpl_ghostscript

Required KB Items: installed_sw/Ghostscript

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/15/2019

Vulnerability Publication Date: 9/3/2019

Reference Information

CVE: CVE-2018-18073, CVE-2019-10216, CVE-2019-14811, CVE-2019-14813, CVE-2019-14817

IAVB: 2019-B-0081-S