Jenkins < 2.176.4 LTS / 2.197 Multiple Vulnerabilities

Medium Nessus Plugin ID 130099

Synopsis

A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.

Description

The version of Jenkins running on the remote web server is prior to 2.197 or is a version of Jenkins LTS prior to 2.176.4. It is, therefore, affected by multiple vulnerabilities:

- An information disclosure vulnerability exists in the /whoAmI/ URL due to the exposed 'Cookie' HTTP Header. An authenticated, remote attacker can exploit this, via a separate Cross-site scripting (XSS) vulnerability, to disclose potentially sensitive information. (CVE-2019-10405)

- A stored Cross-site scripting (XSS) vulnerability exists in the f:formbox form control due to the form control interpreting its item labels as HTML. An authenticated, remote attacker with permission to control the contents of f:formbox form controls can exploit this to execute arbitrary script code in a user's browser session. (CVE-2019-10402)

- A stored Cross-site scripting (XSS) vulnerability exists in the tooltip for SCM tag actions due to the application not escaping characters in the SCM tag name. An authenticated, remote attacker with permission to control SCM tag names can exploit this to execute arbitrary code in a user's browser session. (CVE-2019-10403)

The version of Jenkins running on the remote web server is also affected by other Cross-site scripting (XSS) vulnerabilities. (CVE-2019-10401, CVE-2019-10404, CVE-2019-10406)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Jenkins to version 2.197 or later, Jenkins LTS to version 2.176.4 or later.

See Also

https://jenkins.io/security/advisory/2019-09-25/

Plugin Details

Severity: Medium

ID: 130099

File Name: jenkins_2_197.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/10/21

Updated: 2019/10/31

Dependencies: 65054

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-10405

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins, cpe:/a:jenkins:jenkins

Required KB Items: www/Jenkins

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/25

Vulnerability Publication Date: 2019/09/25

Reference Information

CVE: CVE-2019-10401, CVE-2019-10402, CVE-2019-10403, CVE-2019-10404, CVE-2019-10405, CVE-2019-10406