Oracle Primavera Unifier Multiple Vulnerabilities (Oct 2019 CPU)

High Nessus Plugin ID 130070

Synopsis

An application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Oracle Primavera Unifier installation running on the remote web server is 16.1.x or 16.2.x prior to 16.2.15.10, or 17.7.x through 17.12.x prior to 17.12.11.1, or 18.8.x prior to 18.8.13.0. It is, therefore, affected by multiple vulnerabilities:

- An unspecified flaw exists in how 'default typing' is handled when 'ehcache' is used in the jackson-databind component of Primavera Unifier. An unauthenticated, remote attacker can exploit this via the network over HTTP to cause remote code execution. (CVE-2019-14379)

- An information disclosure vulnerability exists in the jackson-databind component of Primavera Unifier.
An unauthenticated, remote attacker can exploit this via an externally exposed JSON endpoint if the service has the mysql-connector-java jar in the classpath, and the attacker can host a crafted MySQL server accessible by the victim. An attacker can send a crafted JSON message to read arbitrary local files on the server. (CVE-2019-12086)

- An information disclosure vulnerability exists in the jackson-databind component of Primavera Unifier.
An unauthenticated, remote attacker can exploit this via an externally exposed JSON endpoint if the service has the logback jar in the classpath, which can allow information disclosure. (CVE-2019-14439)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Oracle Primavera Unifier version 16.2.15.10 / 17.12.11.1 / 18.8.13.0 or later.

See Also

http://www.nessus.org/u?b370bc74

Plugin Details

Severity: High

ID: 130070

File Name: oracle_primavera_unifier_cpu_oct_2019.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/21

Updated: 2019/10/30

Dependencies: 101904

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-14379

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: x-cpe:/a:oracle:primavera_unifier

Required KB Items: installed_sw/Oracle Primavera Unifier, www/weblogic

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/10/15

Vulnerability Publication Date: 2019/10/15

Reference Information

CVE: CVE-2017-12626, CVE-2019-11358, CVE-2019-12086, CVE-2019-14379, CVE-2019-14439

BID: 102879, 108023, 109227

IAVA: 2019-A-0380