WordPress < 5.2.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 129849

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities

Description

According to its self-reported version number, the WordPress application running on the remote web server is affected by multiple vulnerabilities:
- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.
- An information disclosure vulnerability exists in Wordpress. An unauthenticated, remote attacker can exploit this to disclose potentially sensitive information regarding unauthenticated posts.

- A server-side request forgery vulnerability exists in Wordpress due to insufficient validation of URLs. An unauthenticated, remote attacker can exploit this, by submitting specifically crafted URLs, to cause the server to make requests on their behalf. Successful attacks may allow an attacker to request / update data which was not intended to be accessed by a user of the application.
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 5.2.4 or later.

See Also

https://wordpress.org/support/wordpress-version/version-5-2-4/

Plugin Details

Severity: Medium

ID: 129849

File Name: wordpress_5_2_4.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2019/10/15

Updated: 2019/12/20

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-17671

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/10/14

Vulnerability Publication Date: 2019/10/14

Reference Information

CVE: CVE-2019-17671