Puppet Enterprise x < 2018.1.9 / 2019.x.x < 2019.0.3 Default Password Vulnerabilities

High Nessus Plugin ID 129763

Synopsis

A web application running on the remote host is affected by multiple vulnerabilities.

Description

The admin account is using a default password. An unauthenticated, remote attacker can exploit this gain privileged or administrator access to the system.

Solution

Upgrade to Puppet Enterprise version 2018.1.9, 2019.0.3, or later.

See Also

https://puppet.com/security/cve/CVE-2019-10694

Plugin Details

Severity: High

ID: 129763

File Name: puppet_enterprise_2019_0_3.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2020/03/20

Dependencies: 66234, 66233

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-10694

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/22

Vulnerability Publication Date: 2019/04/30

Reference Information

CVE: CVE-2019-10694