Puppet Enterprise 2018.x < 2018.1.1 Code Execution Vulnerability

High Nessus Plugin ID 129761


A web application running on the remote host is affected by a code execution vulnerability.


According to its self-reported version number, the Puppet install running on the remote host is version 5.5.x prior to 2018.1.1. It is, therefore, affected by a code execution vulnerability when upgrading the pe-razor-server component.


Upgrade to Puppet Enterprise version 2018.1.1 or later.

See Also


Plugin Details

Severity: High

ID: 129761

File Name: puppet_enterprise_2018_1_1.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66234, 66233

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6512

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/06/07

Vulnerability Publication Date: 2018/06/07

Reference Information

CVE: CVE-2018-6512