Puppet Enterprise < 2017.3.4 Code Execution Vulnerability

Medium Nessus Plugin ID 129758

Synopsis

A web application running on the remote host is affected by a code execution vulnerability.

Description

According to its self-reported version number, the Puppet install running on the remote host is version 5.5.x prior to 2017.3.4. It is, therefore, affected by multiple vulnerabilities:

- a remote code execution vulnerability due to incorrect validation of strings in the facter_task or puppet_conf tasks. An unauthenticated remote attacker can exploit this issue to send a specially crafted string into the affected tasks to remotely execute code. (CVE-2018-6508)

- an information disclosure vulnerability exists. An unauthenticated remote attacker can exploit this issue to retrieve a facts from an environment it was not classified to retrieve from. (CVE-2017-10690)

Solution

Upgrade to Puppet Enterprise version 2016.4.12 / 2017.3.7 / 2018.1.1 or later.

See Also

https://puppet.com/security/cve/CVE-2017-10690

https://puppet.com/security/cve/CVE-2018-6508

Plugin Details

Severity: Medium

ID: 129758

File Name: puppet_enterprise_2017_3_4.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66233, 66234

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-6508

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/06/07

Vulnerability Publication Date: 2018/06/07

Reference Information

CVE: CVE-2017-10690, CVE-2018-6508

BID: 103020