Puppet Enterprise < 2017.2.2 Arbitrary Code Execution Vulnerability

Medium Nessus Plugin ID 129757


A web application running on the remote host is affected by a code execution vulnerability.


According to its self-reported version number, the Puppet install running on the remote host is version 5.5.x prior to 2017.2.2. It is, therefore, affected by a denial of service vulnerability which exists in RBAC and classifier errors. An unauthenticated, attacker can exploit this, to use specially formatted strings w/ specific characters as classifier node group names or RBAC role display names to crash the service.


Upgrade to Puppet Enterprise version 2016.4.12 / 2017.3.7 / 2018.1.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 129757

File Name: puppet_enterprise_2017_2_2.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66234, 66233

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-2296

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/06/22

Vulnerability Publication Date: 2017/06/22

Reference Information

CVE: CVE-2017-2296