Puppet Enterprise < 2017.2.2 Arbitrary Code Execution Vulnerability
Medium Nessus Plugin ID 129757
SynopsisA web application running on the remote host is affected by a code execution vulnerability.
DescriptionAccording to its self-reported version number, the Puppet install running on the remote host is version 5.5.x prior to 2017.2.2. It is, therefore, affected by a denial of service vulnerability which exists in RBAC and classifier errors. An unauthenticated, attacker can exploit this, to use specially formatted strings w/ specific characters as classifier node group names or RBAC role display names to crash the service.
SolutionUpgrade to Puppet Enterprise version 2016.4.12 / 2017.3.7 / 2018.1.1 or later.