Puppet Enterprise 2015.x < 2016.4.0 Denial of Service Vulnerability

Medium Nessus Plugin ID 129756


A web application running on the remote host is affected by a denial of service vulnerability.


According to its self-reported version number, the Puppet install running on the remote host is version 5.5.x prior to 2017.2.2. It is, therefore, affected by a denial of service (DoS) vulnerability which exists in the puppet communications protocol broker due to incorrect validation of message header sizes. An unauthenticated remote attacker can exploit this issue to creash the pcp broker and prevent commands from being seint to agents.


Upgrade to Puppet Enterprise version 2016.4.0 or later.

See Also


Plugin Details

Severity: Medium

ID: 129756

File Name: puppet_enterprise_2016_5_1.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66233, 66234

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-9686

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/09/22

Vulnerability Publication Date: 2016/10/14

Reference Information

CVE: CVE-2016-9686

BID: 96319