Puppet Enterprise < 2016.2.1 Multiple Vulnerabilities

High Nessus Plugin ID 129753

Synopsis

A web application running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Puppet Enterprise application running on the remote host is version prior to 2016.2.1. It is, therefore, affected by the following vulnerabilities :

- A remote code execution vulnerability exists in the mcollective puppet-agent plugin due to an insecure argument. An unauthenticated, remote attacker can exploit this to enable remote code execution . (CVE-2015-7331)

- A flaw exists in the Puppet Enterprise Console due to unsafe string processing that allows an authenticated, remote attacker to execute arbitrary code. (CVE-2016-2788)

Solution

Upgrade to Puppet Enterprise version 2016.2.1 or later.

See Also

https://puppet.com/security/cve/CVE-2015-7331

https://puppet.com/security/cve/CVE-2016-2788

Plugin Details

Severity: High

ID: 129753

File Name: puppet_enterprise_2016_2_1.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66234, 66233

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-2788

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/08/09

Vulnerability Publication Date: 2016/08/09

Reference Information

CVE: CVE-2015-7331, CVE-2016-2788

BID: 92096, 92432