Puppet Enterprise 2015.x < 2015.3.3 Multiple Vulnerabilities

High Nessus Plugin ID 129752

Synopsis

A web application running on the remote host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Puppet Enterprise application running on the remote host is version 2015.x prior to 2015.3.3. It is, therefore, affected by the following vulnerabilities :

- A invalid validation of the server certificate by the pxp-agent. An unauthenticated, remote attacker can impersonate a broker and issue commands to the agent. This requires a secondary attack which forces the agent to connect to the malicious broker.
(CVE-2016-2786)

- A denial of service vulnerability exists due to the incorrect validation of the broker node certificates. An unauthenticated, remote attacker can prevent the puppet communications protocol from triggering runs. (CVE-2016-2787)

Solution

Upgrade to Puppet Enterprise version 2015.3.3 or later.

See Also

https://puppet.com/security/cve/cve-2016-2786

https://puppet.com/security/cve/cve-2016-2787

Plugin Details

Severity: High

ID: 129752

File Name: puppet_enterprise_2015_3_3.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/09

Updated: 2019/10/17

Dependencies: 66234, 66233

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-2786

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:puppetlabs:puppet

Required KB Items: puppet/rest_port, installed_sw/puppet_enterprise_console

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/03/14

Vulnerability Publication Date: 2016/03/14

Reference Information

CVE: CVE-2016-2786, CVE-2016-2787

BID: 91163, 96359