phpMyAdmin <= 4.9.1 Cross-Site Request Forgery Vulnerability

Medium Nessus Plugin ID 129696


The remote web server hosts a PHP application that is affected by a cross-site request forgery vulnerability


A cross-site request forgery (XSRF) vulnerability exists in the Setup page of phpMyAdmin. A remote attacker can exploit this by tricking a user into visiting a specially crafted web page, allowing the attacker to delete any server in the setup page by creating a fake hyperlink containing the malicious request it wants the victim's web browser to execute.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to phpMyAdmin version 4.9.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 129696

File Name: phpmyadmin_pmasa_4_9_1.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2019/10/08

Updated: 2019/10/31

Dependencies: 17219

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-12922

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/09/21

Vulnerability Publication Date: 2019/09/21

Reference Information

CVE: CVE-2019-12922

CWE: 352