Debian DSA-4542-1 : jackson-databind - security update

High Nessus Plugin ID 129597

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that jackson-databind, a Java library used to parse JSON and other data formats, did not properly validate user input before attempting deserialization. This allowed an attacker providing maliciously crafted input to perform code execution, or read arbitrary files on the server.

Solution

Upgrade the jackson-databind packages.

For the oldstable distribution (stretch), these problems have been fixed in version 2.8.6-1+deb9u6.

For the stable distribution (buster), these problems have been fixed in version 2.9.8-3+deb10u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941530

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940498

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=933393

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=930750

http://www.nessus.org/u?61134ddf

https://packages.debian.org/source/stretch/jackson-databind

https://packages.debian.org/source/buster/jackson-databind

https://www.debian.org/security/2019/dsa-4542

Plugin Details

Severity: High

ID: 129597

File Name: debian_DSA-4542.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/10/07

Updated: 2019/11/12

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:jackson-databind, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2019/10/06

Vulnerability Publication Date: 2019/06/24

Reference Information

CVE: CVE-2019-12384, CVE-2019-14439, CVE-2019-14540, CVE-2019-16335, CVE-2019-16942, CVE-2019-16943

DSA: 4542