Apple iOS < 13.0 Multiple Vulnerabilities

High Nessus Plugin ID 129587

Synopsis

The version of Apple iOS running on the mobile device is affected by multiple vulnerabilities.

Description

The version of Apple iOS running on the mobile device is prior to 13.0. It is, therefore, affected by multiple vulnerabilities.

- A remote attacker may be able to cause unexpected application termination or arbitrary code execution in iOS Foundation. (CVE-2019-8641)

- A cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input before returning it to users. Processing maliciously crafted web content during WebKit page loading may lead to universal cross site scripting. (CVE-2019-8674)

- An information disclosure vulnerability exists in iOS Keyboards. An authenticated, local attacker can exploit this, to disclose potentially sensitive information. (CVE-2019-8704)

- An out-of-bounds read error exists in CoreAudio. An authenticated, local attacker can exploit this, via processing a maliciously crafted movie may result in the disclosure of process memory. (CVE-2019-8705)

- A logic issue existed in with display notifications of iOS Bluetooth. Notification previews may show on bluetooth accessories even when previews are disabled. (CVE-2019-8711)

- A logic issue was addressed in iOS Safari. An authenticated, local attacker can exploit this, by Visiting a malicious website may lead to address bar spoofing. (CVE-2019-8727)

- An information disclosure vulnerability exists in iOS Quick look. A permission issue existed in which execute permission was incorrectly granted. Processing malicious crafted file may disclose sensitive users information. (CVE-2019-8731)

- An information disclosure vulnerability exists in iOS Messages. A person with physical access to an iOS device may be able to access contacts from the lock screen. (CVE-2019-8742)

- A machine learning logic bug exists in iOS FaceID. A 3D model constructed to look like the enrolled user may authenticate via Face ID. (CVE-2019-8760)

Solution

Upgrade to Apple iOS version 13.0 or later

See Also

https://support.apple.com/en-us/HT210606

Plugin Details

Severity: High

ID: 129587

File Name: apple_ios_130_check.nbin

Version: 1.7

Type: local

Published: 2019/10/04

Updated: 2020/06/12

Dependencies: 60033

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-8641

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Required KB Items: mdm/dependency/unlocked

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/09/23

Vulnerability Publication Date: 2019/09/23

Reference Information

CVE: CVE-2019-8641, CVE-2019-8674, CVE-2019-8704, CVE-2019-8705, CVE-2019-8711, CVE-2019-8727, CVE-2019-8731, CVE-2019-8742, CVE-2019-8760

BID: 109332

APPLE-SA: APPLE-SA-2019-09-23