PHP 7.3.x < 7.3.10 Heap-Based Buffer Overflow Vulnerability.

High Nessus Plugin ID 129557

Synopsis

An application installed on the remote host is affected by a head-based buffer overflow vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.10. It is, therefore, affected by a heap-based buffer overflow vulnerability in its mb_eregi component due to insufficient validation of user input. An unauthenticated, remote attacker can exploit this, by sending a specially crafted request, to cause a denial of service condition or the execution of arbitrary code

Solution

Upgrade to PHP version 7.3.10 or later.

See Also

https://www.php.net/ChangeLog-7.php#PHP_7_3

https://bugs.php.net/bug.php?id=78559

Plugin Details

Severity: High

ID: 129557

File Name: php_7_3_10.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/10/04

Updated: 2019/11/01

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Patch Publication Date: 2019/09/26

Vulnerability Publication Date: 2019/09/26