EulerOS 2.0 SP8 : pango (EulerOS-SA-2019-2088)

High Nessus Plugin ID 129447

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the pango packages installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- Gnome Pango 1.42 and later is affected by: Buffer Overflow. The impact is: The heap based buffer overflow can be used to get code execution. The component is:
function name: pango_log2vis_get_embedding_levels, assignment of nchars and the loop condition. The attack vector is: Bug can be used when application pass invalid utf-8 strings to functions like pango_itemize.(CVE-2019-1010238)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected pango package.

See Also

http://www.nessus.org/u?b220fc55

Plugin Details

Severity: High

ID: 129447

File Name: EulerOS_SA-2019-2088.nasl

Version: 1.1

Type: local

Published: 2019/09/30

Updated: 2019/09/30

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:pango, p-cpe:/a:huawei:euleros:pango-devel, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2019/09/29

Reference Information

CVE: CVE-2019-1010238