EulerOS 2.0 SP8 : gd (EulerOS-SA-2019-2074)

Medium Nessus Plugin ID 129433

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the gd package installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- When using the gdImageCreateFromXbm() function in the GD Graphics Library (aka LibGD) 2.2.5, as used in the PHP GD extension in PHP versions 7.1.x below 7.1.30, 7.2.x below 7.2.19 and 7.3.x below 7.3.6, it is possible to supply data that will cause the function to use the value of uninitialized variable. This may lead to disclosing contents of the stack that has been left there by previous code.(CVE-2019-11038)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected gd package.

See Also

http://www.nessus.org/u?02b62dba

Plugin Details

Severity: Medium

ID: 129433

File Name: EulerOS_SA-2019-2074.nasl

Version: 1.1

Type: local

Published: 2019/09/30

Updated: 2019/09/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:gd, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2019/09/29

Reference Information

CVE: CVE-2019-11038