Scientific Linux Security Update : kernel on SL7.x x86_64

High Nessus Plugin ID 129152

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- A buffer overflow flaw was found in the way Linux kernel's vhost functionality that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descriptors with invalid length to the host when migration is underway, could use this flaw to increase their privileges on the host. (CVE-2019-14835)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?c47f41ee

Plugin Details

Severity: High

ID: 129152

File Name: sl_20190920_kernel_on_SL7_x.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/09/23

Updated: 2019/11/12

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2019/09/20

Vulnerability Publication Date: 2019/09/17

Reference Information

CVE: CVE-2019-14835