EulerOS 2.0 SP2 : ruby (EulerOS-SA-2019-1868)

Medium Nessus Plugin ID 128920

Synopsis

The remote EulerOS host is missing a security update.

Description

According to the version of the ruby packages installed, the EulerOS installation on the remote host is affected by the following vulnerability :

- The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.(CVE-2016-7798)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected ruby package.

See Also

http://www.nessus.org/u?41bccbee

Plugin Details

Severity: Medium

ID: 128920

File Name: EulerOS_SA-2019-1868.nasl

Version: 1.1

Type: local

Published: 2019/09/17

Updated: 2019/09/17

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:ruby, p-cpe:/a:huawei:euleros:ruby-irb, p-cpe:/a:huawei:euleros:ruby-libs, cpe:/o:huawei:euleros:2.0

Required KB Items: Host/local_checks_enabled, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/sp

Excluded KB Items: Host/EulerOS/uvp_version

Patch Publication Date: 2019/09/11

Reference Information

CVE: CVE-2016-7798