Debian DSA-4521-1 : docker.io - security update

critical Nessus Plugin ID 128622

Synopsis

The remote Debian host is missing a security-related update.

Description

Three security vulnerabilities have been discovered in the Docker container runtime: Insecure loading of NSS libraries in 'docker cp'could result in execution of code with root privileges, sensitive data could be logged in debug mode and there was a command injection vulnerability in the 'docker build' command.

Solution

Upgrade the docker.io packages.

For the stable distribution (buster), these problems have been fixed in version 18.09.1+dfsg1-7.1+deb10u1.

See Also

https://security-tracker.debian.org/tracker/source-package/docker.io

https://packages.debian.org/source/buster/docker.io

https://www.debian.org/security/2019/dsa-4521

Plugin Details

Severity: Critical

ID: 128622

File Name: debian_DSA-4521.nasl

Version: 1.4

Type: local

Agent: unix

Published: 9/10/2019

Updated: 12/6/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:docker.io, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2019

Vulnerability Publication Date: 7/18/2019

Reference Information

CVE: CVE-2019-13139, CVE-2019-13509, CVE-2019-14271

DSA: 4521