GLSA-201909-03 : Pango: Buffer overflow

High Nessus Plugin ID 128592

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201909-03 (Pango: Buffer overflow)

A buffer overflow has been discovered in Pango’s pango_log2vis_get_embedding_levels function.
Impact :

A remote attacker could entice a user to process a specially crafted string with functions like pango_itemize, possibly resulting in execution of arbitrary code with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All Pango users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/pango-1.42.4-r2'

See Also

https://security.gentoo.org/glsa/201909-03

Plugin Details

Severity: High

ID: 128592

File Name: gentoo_GLSA-201909-03.nasl

Version: 1.1

Type: local

Published: 2019/09/09

Updated: 2019/09/09

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:pango, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/09/06

Vulnerability Publication Date: 2019/07/19

Reference Information

CVE: CVE-2019-1010238

GLSA: 201909-03