Debian DSA-4518-1 : ghostscript - security update

High Nessus Plugin ID 128560

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that various procedures in Ghostscript, the GPL PostScript/PDF interpreter, do not properly restrict privileged calls, which could result in bypass of file system restrictions of the dSAFER sandbox.

Solution

Upgrade the ghostscript packages.

For the oldstable distribution (stretch), these problems have been fixed in version 9.26a~dfsg-0+deb9u5.

For the stable distribution (buster), these problems have been fixed in version 9.27~dfsg-2+deb10u2.

See Also

https://security-tracker.debian.org/tracker/source-package/ghostscript

https://packages.debian.org/source/stretch/ghostscript

https://packages.debian.org/source/buster/ghostscript

https://www.debian.org/security/2019/dsa-4518

Plugin Details

Severity: High

ID: 128560

File Name: debian_DSA-4518.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/09/09

Updated: 2019/12/31

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, cpe:/o:debian:debian_linux:10.0, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/07

Vulnerability Publication Date: 2019/09/03

Reference Information

CVE: CVE-2019-14811, CVE-2019-14812, CVE-2019-14813, CVE-2019-14817

DSA: 4518

IAVB: 2019-B-0081