WordPress <= 3.6.1 / 3.7.x < 3.7.30 / 3.8.x < 3.8.30 / 3.9.x < 3.9.28 / 4.0.x < 4.0.27 / 4.1.x < 4.1.27 / 4.2.x < 4.2.24 / 4.3.x < 4.3.20 / 4.4.x < 4.4.19 / 4.5.x < 4.5.18 / 4.6.x < 4.6.15 / 4.7.x < 4.7.14 / 4.8.x < 4.8.10 / 4.9.x < 4.9.11 / 5.0.x < 5.0.6 / 5.1.x < 5.1.2 / 5.2.x < 5.2.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 128554

Synopsis

Checks the version of WordPress.

Description

According to its self-reported version number, the WordPress application running on the remote web server is affected by multiple vulnerabilities:
- An open redirect vulnerability exists in WordPress due to improper sanitization of user-supplied input to HTTP request parameters. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted link, to redirect a user to a malicious website. (CVE-2019-16220)

- Multiple cross-site scripting (XSS) vulnerabilities exist in WordPress due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session. (CVE-2019-16217, CVE-2019-16218, CVE-2019-16219, CVE-2019-16221, CVE-2019-16222, CVE-2019-16223)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to WordPress version 3.7.30 / 3.8.30 / 3.9.28 / 4.0.27 / 4.1.27 / 4.2.24 / 4.3.20 / 4.4.19 / 4.5.18 / 4.6.15 / 4.7.14 / 4.8.10 / 4.9.11 / 5.0.6 / 5.1.2 / 5.2.3 or later.

See Also

http://www.nessus.org/u?721eeb41

https://codex.wordpress.org/WordPress_Versions

https://wordpress.org/support/wordpress-version/version-3-7-30/

https://wordpress.org/support/wordpress-version/version-3-8-30/

https://wordpress.org/support/wordpress-version/version-3-9-28/

https://wordpress.org/support/wordpress-version/version-4-0-27/

https://wordpress.org/support/wordpress-version/version-4-1-27/

https://wordpress.org/support/wordpress-version/version-4-2-24/

https://wordpress.org/support/wordpress-version/version-4-3-20/

https://wordpress.org/support/wordpress-version/version-4-4-19/

https://wordpress.org/support/wordpress-version/version-4-5-18/

https://wordpress.org/support/wordpress-version/version-4-6-15/

https://wordpress.org/support/wordpress-version/version-4-7-14/

https://wordpress.org/support/wordpress-version/version-4-8-10/

https://wordpress.org/support/wordpress-version/version-4-9-11/

https://wordpress.org/support/wordpress-version/version-5-0-6/

https://wordpress.org/support/wordpress-version/version-5-1-2/

https://wordpress.org/support/wordpress-version/version-5-2-3/

Plugin Details

Severity: Medium

ID: 128554

File Name: wordpress_5_2_3.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2019/09/09

Updated: 2019/10/31

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-16220

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/04

Vulnerability Publication Date: 2019/09/04

Reference Information

CVE: CVE-2019-16217, CVE-2019-16218, CVE-2019-16219, CVE-2019-16220, CVE-2019-16221, CVE-2019-16222, CVE-2019-16223