WordPress <= 3.6.1 / 3.7.x < 3.7.30 / 3.8.x < 3.8.30 / 3.9.x < 3.9.28 / 4.0.x < 4.0.27 / 4.1.x < 4.1.27 / 4.2.x < 4.2.24 / 4.3.x < 4.3.20 / 4.4.x < 4.4.19 / 4.5.x < 4.5.18 / 4.6.x < 4.6.15 / 4.7.x < 4.7.14 / 4.8.x < 4.8.10 / 4.9.x < 4.9.11 / 5.0.x < 5.0.6 / 5.1.x < 5.1.2 / 5.2.x < 5.2.3 Multiple Vulnerabilities
Medium Nessus Plugin ID 128554
SynopsisChecks the version of WordPress.
DescriptionAccording to its self-reported version number, the WordPress application running on the remote web server is affected by multiple vulnerabilities:
- An open redirect vulnerability exists in WordPress due to improper sanitization of user-supplied input to HTTP request parameters. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted link, to redirect a user to a malicious website. (CVE-2019-16220)
- Multiple cross-site scripting (XSS) vulnerabilities exist in WordPress due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session. (CVE-2019-16217, CVE-2019-16218, CVE-2019-16219, CVE-2019-16221, CVE-2019-16222, CVE-2019-16223)
Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.
SolutionUpgrade to WordPress version 3.7.30 / 3.8.30 / 3.9.28 / 4.0.27 / 4.1.27 / 4.2.24 / 4.3.20 / 4.4.19 / 4.5.18 / 4.6.15 / 4.7.14 / 4.8.10 / 4.9.11 / 5.0.6 / 5.1.2 / 5.2.3 or later.