Exim < 4.92.2

Critical Nessus Plugin ID 128553


The remote mail server is potentially affected by a remote code execution vulnerability.


According to its banner, the version of Exim running on the remote host is prior to 4.92.2. It is, therefore, potentially affected by a remote code execution vulnerability allowing unauthenticated, remote attackers to execute arbitrary code as root via a trailing backslash.


Upgrade to Exim 4.92.2 or later.

See Also


Plugin Details

Severity: Critical

ID: 128553

File Name: exim_4_92_2.nasl

Version: 1.4

Type: remote

Published: 2019/09/06

Updated: 2019/10/17

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2019-15846

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/09/02

Vulnerability Publication Date: 2019/09/02

Reference Information

CVE: CVE-2019-15846