Exim < 4.92.2

critical Nessus Plugin ID 128553
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote mail server is potentially affected by a remote code execution vulnerability.

Description

According to its banner, the version of Exim running on the remote host is prior to 4.92.2. It is, therefore, potentially affected by a remote code execution vulnerability allowing unauthenticated, remote attackers to execute arbitrary code as root via a trailing backslash.

Solution

Upgrade to Exim 4.92.2 or later.

See Also

https://exim.org/static/doc/security/CVE-2019-15846.txt

Plugin Details

Severity: Critical

ID: 128553

File Name: exim_4_92_2.nasl

Version: 1.4

Type: remote

Published: 9/6/2019

Updated: 10/17/2019

Dependencies: smtpserver_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-15846

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/2/2019

Vulnerability Publication Date: 9/2/2019

Reference Information

CVE: CVE-2019-15846