Atlassian Confluence 6.1.x < 6.6.16 / 6.7.x < 6.13.7 / 6.14.x < 6.15.8 Local File Disclosure Vulnerability

Medium Nessus Plugin ID 128548

Synopsis

A web application running on the remote host is affected by a local file disclosure vulnerability

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is 6.1.x prior to 6.6.16, 6.7.x prior to 6.13.7, 6.14.x prior to 6.15.8. It is, therefore, affected by a local file disclosure vulnerability which exists in page export component. An authenticated, remote attacker with AddPage space permission can exploit this to read arbitrary files in the <install-directory>/confluence/WEB-INF directory.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 6.6.16, 6.13.7, 6.13.4, 6.14.3, 6.15.2 or later.

See Also

http://www.nessus.org/u?d906d699

Plugin Details

Severity: Medium

ID: 128548

File Name: confluence_6_15_8.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/09/06

Updated: 2019/10/17

Dependencies: 53574

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-3394

CVSS v2.0

Base Score: 4

Temporal Score: 3.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/confluence, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/08/28

Vulnerability Publication Date: 2019/08/28

Reference Information

CVE: CVE-2019-3394