PHP 7.3.x < 7.3.9 Multiple Vulnerabilities.

High Nessus Plugin ID 128531

Synopsis

An application installed on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP running on the remote web server is 7.3.x prior to 7.3.9. It is, therefore, affected by multiple vulnerabilities including an unspecified heap buffer overflow.

Solution

Upgrade to PHP version 7.3.9 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.3.9

https://bugs.php.net/bug.php?id=78213

Plugin Details

Severity: High

ID: 128531

File Name: php_7_3_9.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2019/09/05

Updated: 2020/01/10

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-13224

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP, installed_sw/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/08/29

Vulnerability Publication Date: 2019/08/29

Reference Information

CVE: CVE-2019-13224