Scientific Linux Security Update : rsyslog on SL7.x x86_64 (20190806)

Medium Nessus Plugin ID 128259

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

Security Fix(es) :

- rsyslog: imptcp: integer overflow when Octet-Counted TCP Framing is enabled (CVE-2018-16881)

Solution

Update the affected packages.

See Also

http://www.nessus.org/u?e5678b65

Plugin Details

Severity: Medium

ID: 128259

File Name: sl_20190806_rsyslog_on_SL7_x.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/08/27

Updated: 2020/02/24

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fermilab:scientific_linux:rsyslog, p-cpe:/a:fermilab:scientific_linux:rsyslog-crypto, p-cpe:/a:fermilab:scientific_linux:rsyslog-debuginfo, p-cpe:/a:fermilab:scientific_linux:rsyslog-doc, p-cpe:/a:fermilab:scientific_linux:rsyslog-elasticsearch, p-cpe:/a:fermilab:scientific_linux:rsyslog-gnutls, p-cpe:/a:fermilab:scientific_linux:rsyslog-gssapi, p-cpe:/a:fermilab:scientific_linux:rsyslog-kafka, p-cpe:/a:fermilab:scientific_linux:rsyslog-libdbi, p-cpe:/a:fermilab:scientific_linux:rsyslog-mmaudit, p-cpe:/a:fermilab:scientific_linux:rsyslog-mmjsonparse, p-cpe:/a:fermilab:scientific_linux:rsyslog-mmkubernetes, p-cpe:/a:fermilab:scientific_linux:rsyslog-mmnormalize, p-cpe:/a:fermilab:scientific_linux:rsyslog-mmsnmptrapd, p-cpe:/a:fermilab:scientific_linux:rsyslog-mysql, p-cpe:/a:fermilab:scientific_linux:rsyslog-pgsql, p-cpe:/a:fermilab:scientific_linux:rsyslog-relp, p-cpe:/a:fermilab:scientific_linux:rsyslog-snmp, p-cpe:/a:fermilab:scientific_linux:rsyslog-udpspoof, x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/08/06

Vulnerability Publication Date: 2019/01/25

Reference Information

CVE: CVE-2018-16881