Exim < 4.92.1 Input-Validation RCE

critical Nessus Plugin ID 128036
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote mail server is potentially affected by a remote code execution vulnerability.


According to its banner, the version of Exim running on the remote host is prior to 4.92.1. It is, therefore, potentially affected an input-validation flaw in the '${sort }' expansion. A remote attacker could potentially execute arbitrary code.

Note that the default configuration does not include '${sort }'.


Upgrade to Exim 4.92.1 or later.

See Also



Plugin Details

Severity: Critical

ID: 128036

File Name: exim_4_92_1.nasl

Version: 1.3

Type: remote

Published: 8/20/2019

Updated: 10/17/2019

Dependencies: smtpserver_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-13917


Risk Factor: Medium

Score: 5.9


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 7/18/2019

Vulnerability Publication Date: 7/18/2019

Reference Information

CVE: CVE-2019-13917

BID: 109338