Exim < 4.92.1 Input-Validation RCE

Critical Nessus Plugin ID 128036

Synopsis

The remote mail server is potentially affected by a remote code execution vulnerability.

Description

According to its banner, the version of Exim running on the remote host is prior to 4.92.1. It is, therefore, potentially affected an input-validation flaw in the '${sort }' expansion. A remote attacker could potentially execute arbitrary code.

Note that the default configuration does not include '${sort }'.

Solution

Upgrade to Exim 4.92.1 or later.

See Also

https://exim.org/static/doc/security/CVE-2019-13917.txt

https://ftp.exim.org/pub/exim/exim4/ChangeLog

Plugin Details

Severity: Critical

ID: 128036

File Name: exim_4_92_1.nasl

Version: 1.2

Type: remote

Published: 2019/08/20

Updated: 2019/09/13

Dependencies: 10263

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2019-13917

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2019/07/18

Vulnerability Publication Date: 2019/07/18

Reference Information

CVE: CVE-2019-13917

BID: 109338